Android app crashes on local sync attempt

Hi Andrei,

I’m using Everdo 1.5.8 (Pro) on Linux Mint. My Android app version (after update) is 1.2-19 on Android 10; this error already happened before the app update, though, which I tried to fix the error. I don’t know which app version I had previously.

Sync worked fine for over a year, but today, the app keeps crashing when I try. Either that (most of the time) or the message “Communication error” will pop up (happened once - other times, it would just crash).

I checked that I’m connected to the same wifi with both devices. I also went back to check that the API key, IP and port are still the same in the Everdo settings on both devices (and that the IP matches the system-wide IP on the desktop). They do.

Trying to access*** on my desktop gives me {"server_time_ms":1620592810257} while it gives me {"server_time_ms":1620593027499} on my phone (a bit later).

Do you have any idea, what could be wrong? I can’t remember changing any settings. Is there any kind of log that I could provide to you?

Best regards,

Hello Henrik

Do you get a dialog to send an error report when the app crashes? if so then please do send it.

Have you tried pull or clean pull from the desktop to the phone?

Then next thing to try would be to reinstall the app on the phone and try to sync again starting from scratch.

If that doesn’t help, try one of the older versions to find the latest that works. Then I could have more ideas for fixing the issue.

Hi Andrei,

I sometimes (most of the time not) do get the crash report. I sent it to you via “Give feedback” after the crash. I hope, that report will reach you?!

I have used the app, created, edited and moved tasks and notebooks, on both the Desktop and Android that are not synced (before I noticed the problem). So I’d really appreciate if we could fix this without losing the changes on one side. :slight_smile:

Next thing that comes to my mind is a reinstall of the app. I guess, I won’t lose data then?!

Best regards

Unfortunately the reports are not coming so far. I’m looking for a way to resolve this without losing any data.

Uninstalling the app on Android will wipe all data, so definitely don’t do that.

You could go to settings and execute “Export to JSON” first. Then you will be able to restore all the items and their contents. However importing a JSON data file will not merge conflicting changes - all matching items will be overwritten with the version that is in JSON. It’s not designed to preserve change history, which is necessary for conflict resolution.

One more question:

Do you get the crash both when initiating sync from the settings and when using the swipe down gesture?

Are we talking about the same thing, though? This is in the way of what I mean. Here I pressed “Send feedback”. I thought this will reach you. I could do a logcat or something similar if you need that.

Thanks for the hints! I probably would have done a reinstall today with import and export of JSON. Now, I won’t. :wink:

I was not aware, I can do it from the settings, as well. Really good hint! I could perform the two-way sync from the settings. :slight_smile: Pulling down still makes the app crash, though.

Thank you, it should appear eventually.

Great news! This will help with diagnostics.

Just wanted to let you know, after exchanging a lot of messages with Andrei and bugfixing on his side, everything works fine now. Thanks, @Andrei! :slight_smile:


I have the exact same issue as well.

I am just trying out Everdo. It would have everything I want but without an app its useless to me.

oh, and please, please share your solutions as well if you ask for help on the internet.
Maybe, someone has the same problem in two years :wink:

Did it start crashing for your right away, or did it work for a while, and then stopped working?

After the crash, does the system ask you to send a bug report? If so, please do.

It started crashing as soon as I set up Network-Sync.
Tried reinstalling and clearing cache several times, even tried a few older builds.

It asked me once or twice to send a bug-report, which I tried, but I think it didn’t go through.

Any Ideas what I can try?

edit: I think I was able to send a report.
Strangely the report-windows closes itself as soon as I try to type in a description. So I sent it without one.

Unfortunately I’m still unable to find any relevant crash reports in Google Play. Just to make sure we are on the same page, please confirm that you are trying to use Local Sync (not ESS sync), and using the Android app.

Please post or PM a screenshot of your sync configuration from both the server app and the client app.