Arch Desktop GUI crashes when dragging items from the Inbox


#1

Hi all,

I’m excited to try out Everdo and see what I can do to help development! So far, it’s been a pleasant experience across my Linux desktop and my Android phone. However, I have been able to reproduce one crash.

OS: Arch Linux
Window manager: bspwm
Everdo version: 1.1.8

Steps

  1. Open Everdo
  2. Create a new item in the inbox
  3. Attempt to drag the item into the sidebar, under “Projects”
  4. Observe the app crash

Video: https://drive.google.com/open?id=1R-A9-Cf-kFrTFOvcH4E9Z8QQsLoajx8o

Let me know if there’s anything else I can do to troubleshoot!

Thanks,
-Seri


#2

Hi there.

First thing, have you updated your system? You probably have, but just to make sure…

Please check the .log file at .config/everdo. Are there errors when the crash happens?

If not, it’s either a bspwm or Electron bug, or a compatibility issue. Do you have other Electron apps working fine, or Chrome/Chromium?

I’m personally running Arch+awesome wm and it’s flawless.


#3

Noticed one more thing: it looks like the crash happens when the draggable item reaches the edge of the window.
I wonder what happens if you drag and drop without touching the edge. Maybe the WM is freaking out when the window’s content gets outside the window.


#4

Thanks Andrei!

  • I’ve updated my system, according to pacman -Syyu
  • The log file at .config/everdo/log.log just states [2018-09-03 12:27:33.708] [error] SSL certificates missing
  • It could possibly be a WM compatibility issue, I’ve had to do one-off fixes for bspwm before. Particularly with JVM apps.
  • I can drag+drop just fine in Chromium
  • The crash occurs as soon as an item is dragged at all from it’s original position. The “dragging artifact” created under the mouse continues to function, but it is initially drawn offset from the actual content.

#5

I just killed compton and restarted the service and it appears to be functioning now— investigating further.


#6

This may be related to transparency-support in Electron apps, see the following issues:


https://bugs.chromium.org/p/chromium/issues/detail?id=854601#c7

I’m headed to work now, but I can investigate more tonight.


#7

I’ve found a more acurate bug report that matches the behavior I’m observing:

So far, I’ve found two workarounds:

  • Disable compton
  • Run everdo with GPU acceleration turned off. e.g. everdo --disable-gpu from the command line.

I’ll post an update if I find more concise fixes.


#8

Thanks for so much info. The github issue does seem relevant. Unfortunately it seems we can’t do much here in Everdo code.


#9

No worries— I don’t mind running everdo without GPU acceleration. In the meantime, it looks like the bug is being decently actively discussed. Hopefully a resolution will be found there.

Regardless, thanks for the active and attentive development! I’m still evaluating Everdo and the whole GTD process, but it looks promising so far!


#10

Hi, for the record, I have the same bug on Ubuntu 18.04 with everdo 1.1.14. Running everdo --disable-gpu does the trick indeed.