[Fixed] Select Tags doesn't show any tags when there are no Areas in the database

Not sure if this is me missing something or a bug, but I don’t seem to be able to access existing tags (created on my laptop and sync’d via encrypted sync) from the Android app. It knows about the tags already attached to the date, but I can’t remove them or add new ones. If I use the ‘+’ button to create a tag with the same name as one which already exists, it shows up as a duplicate when sync’d through to the desktop app.

Screenshot_20191229-205403

Thanks,

Phil

Did you read a doc about synchronization? At the bottom there is a section named “ Manual Sync Actions” which might help you.

Please have a look
https://help.everdo.net/docs/sync/ess/

Thanks Mateusz.

I’ve read the doc, and unfortunately it hasn’t helped. In particular, I’ve tried a ‘push’ and a ‘force push’ from my laptop, which has complete data, and have then tried a ‘clean pull’ on my phone. The tags are still missing.

Hello. Is this issue still happening for you?

The force push / clean pull should definitely take care of syncing the full database between your devices, so this is most likely an Android app bug.

Are the tags missing in the Select Tags view only, or are they missing altogether, including on the individual items in the Next list?

Also, please PM me your ESS account email address, so that I can review the sync log.

Thank you!

Yes, it’s still happening, and the tags are only missing in the ‘select tags’ view - they’re visible everywhere else.

Thanks for investigating - will send my email address by PM.

Phil

@Andrei - have sent by email to info@everdo.net, as I don’t have permission to send you a PM on the forum.

Phil

This definitely indicates a bug with the Android app. It’s quite strange that others don’t seem to experience this issue. What is your Android version?

I got it! Please create at least one Area tag. Then the tag selection view on Android will work properly. There’s an error in code that prevents all tags from showing up if there are no Areas.

Perfect, that’s fixed it - thanks!

Phil