Android 11 local sync

I have replaced my old Nokia (Android 10) with a new Pixel 5 (Android 11) but can’t get local sync to a Debian server to work.

The 2 phones have the same app version, pro key and identical settings. The Nokia syncs immediately but the Pixel just blocks at the “Please wait” message.

I’ve tried to clear cache/storage and reinstalled the app but the behaviour doesn’t change.

I can open the server url (https://server IP:portnum) on both phones and get the same “Cannot GET /” response so doesn’t seem to be a networking issue. Is there a problem with Android 11?


Local sync has been tested on Android 11, so it should work, unless there an unexpected issue.

Could you post a screenshot of what you see when trying to access*** on both devices?

Thanks for getting back to me Andrei.

I just get a 401 response with that url (image attached).

It’s the same for both phones and my win10 laptop. Did you intend for me to replace the “***” in the query string with my key? I tried both but got same result.



Yes, I meant that, sorry for not being clear.

This certainly indicates an invalid API key being passed to the server. Could you check that it’s correct and maybe try setting a different one, without any special characters preferable?

Also try the same request on the server itself.

No problem. I was being stupid … I tried with my activation key rather than the API key (the obvious one, duh :roll_eyes:)

With the API key, my win10 device responds with :

The phones both still give the 401 response. They are not on the same subnet as the win10 device but the Nokia still syncs normally. Only the Pixel refuses to sync even though it is on the same subnet as the Nokia.

I’ve made some progress. I reset the API key on all devices and the server to a new value and I now get the same response on all … {“server_time_ms”:1609419339831} … so the server connection seems to work now.

The Nokia, which was already configured and syncing still works without problem.

The new Pixel is still behaving strangely. It seems to have a problem with the sample entries which are created by default on install.

I’m trying to do a “clean pull” which, I believe, should just replace everything on the client device with a copy of the server data but it doesn’t seem to work. The sample entries are still in the inbox after the “clean pull”. If I send them to trash and try to delete them I get a message asking “Do you want to delete default trash items?” but replying “DELETE” does nothing. It doesn’t seem to be possible to delete the sample entries.

I have tried several times like this and sometimes I get my server data mixed with the sample entries in the inbox and sometimes no server data, just the sample entries … very strange!

Have I misunderstood what the “clean pull” is intended to do?

Yes, this is how it should work. There may be a bug here which needs attention.

If I understand correctly, when you try to empty the trash on Android, nothing happens? What if you move some non-sample items to trash, do they get cleaned up?

What happens when you delete the sample items on the server and sync the phone?

By the way, the wording “Do you want to delete default trash items?” is a bug - it should just be “Do you want to delete the trash items?”. Sorry for the confusion.

Hi Andrei, sorry for delay, I’ve had other stuff to do for the last few days.

Happy new year by the way!

I’ve done some more tests and it seems that :

  1. If I leave sample entries in inbox and do a clean pull then they do not get removed and sometimes I get a data sync and sometimes not.
  2. If I move the sample entries to trash first then do the clean pull the sync seems to be reliable but the sample entires are not removed from trash.
  3. I cannot manually delete the sample entries from trash.
  4. If I turn on autosync then eventually the sample entries disappear from trash.

Once the autosync has had time to clean up the sample entries the app seems to function normally so I don’t really have an issue any more. The behaviour is just a bit unexpected.


Thanks for writing this up. I will investigate what is happening.
Happy new year!