Android app crashing when setting up sync

Hey, I’ve been trying to set up an encrypted sync. The web app works fine, but the android app crashes if I use the QR code, and if I set it up manually it seems to work, but crashes every time it actually tries to sync. Would appreciate your help,

This is being investigated. I will let you know as soon as possible.

Thanks Andrei! Some more info which might help:
It seems that the first quick pairing of the mobile device does not crash, but doesn’t actually pair it either, it says it has succeeded, but when trying to sync it says sync is not configured. If I try to pair it again, it crashes.

There is nothing wrong in the logs on the ESS side so far - all your attempts to pair worked fine as far as the sync service is concerned.

Also there are no crash reports for this incident in Google Play (please try to send if possible, that would help greatly).

Since sync crashes on the phone I suspect that the app receives some data as part of sync that it’s unable to process. Therefore for now I would suggest trying to wipe the ESS data and then to pair the phone again. For example:

  1. Delete all items on the computer from all lists manually and empty Trash (use the JSON export feature beforehand if you would like to recover these items in the future)
  2. Run a Force Push against the ESS to override its data
  3. Try pairing the mobile app again

Cleaning everything and re-pairing worked! Thanks! I’ll make sure to update here if this happens again. I didn’t have much data on there other than the tutorial stuff though, so perhaps something there causes it to act weird?

Anyway, thank you very much!