Android ESS Sync "Certification Path Not Found" Error

Since yesterday I can not sync (ESS) my android phone anymore, my partner is having the same issue (both installed via apk). I have version 1.2-27.
I uninstalled and reinstalled, wiped everything and unlinked my sync account. When I attempt to sign in to set up ESS again I get the following error:

sign in error Trust anchor for certification path not found.

Sync from iOS still works for me.
I looked up the error and found a few unrelated programs where apparently the solution was to fix something server-side. Any ideas?


Do you still experience this issue? I believe it should have been fixed.

Yes, unfortunately I do. My partner’s phone works fine again, it was a different issue that had nothing to do with Everdo. So it might just be me.
At some point yesterday I tried to sign in and got a different error:

sign in error Unable to resolve host “”: No address associated with hostname”

But now it has switched back to the error I originally posted.
I thought maybe my install file was broken (from APKPure) so I uninstalled and got an older version, the latest one you posted here on the forums (1.2-18): same result.

I wouldn’t be surprised if it was my phone since it is older, but it was working fine until just this week, which is the part that’s confusing me.

I think this issue might be specific to you device / OS. Please share your Android version, maybe I’ll be able to reproduce the issue.

Yes that sounds likely, it is a bit of an unusual aka ancient setup.
I’m using a rooted Samsung GT-I8160 running Android 5.1.1 as a CyanogenMod install.

But like I said it worked fine until last week, so I still have hope it’s fixable.

A few weeks ago a legacy root SSL certificate of expired. The new root certificate might not be supported on older operating systems, leading to SSL errors similar to what you have observed in apps and websites that rely on letsencrypt SSL certificates.

You can read about the expiration event here

Ah, intersting! Thanks for the link, makes sense.
So I guess that means I’m screwed for now?

Maybe I can find a more up to date OS/custom rom that accepts the new encryption certificates, hm.