Cannot open app in MacOS Catalina (stored window size too small)


Out of a sudden, I am no longer able to open Everdo app on my Mac. When I try to open the app, nothing shows up. No errors no window no anything. I tried rebooting my MBP a few times, it still doesn’t open.

I’m using Everdo 1.3.9 version on my MacOS Catalina 10.15.5. Is there any known issue currently?

If you need any logs, let me know where I can find them.


Update: I found the Everdo folder inside Applications Support and did some tinkering.

I noticed that in window-state.json, it’s shown as:


I increased the width from 1 to 100, and height from 22 to 220. I now manage to see a small window when launching the app. This allows me to enlarge it and use it as normal.

Is it ok to keep this change permanently? I’m not sure why it shrunk to just 1x22. When I last closed the app it was definitely at a normal size.

The window-state.json file is a way to keep track of the last known position and dimensions of the application window. It looks like somehow the file ended up with small dimensions values that made the window invisible. I’m not sure how this could have happened - nothing similar was reported before.

The file itself is not important and it gets overwritten every time the window changes size, so it doesn’t matter what values you put in there.

I assume that the issue is resolved now, please correct me if not.

Yea it’s resolved now by manually editting window-state.json.

I did some extra testing and I was able to reproduce it as such:

  1. Open Everdo in my MBP


  1. Plug my MBP into a larger screen. Move Everdo into that larger screen and maximized.
  2. Unplug the larger screen from my MBP. Now Everdo is moved back to MBP by system.
  3. Quite Everdo via cmd + q.
  4. Reopen Everdo again. The app now does not show correctly, but it’s due to the positions being off-screen instead of the 1x22 size problem.


  1. Close Everdo again.
  2. Now reopen. The window is now 1x22.


Hope this is useful for your debugging.

1 Like