Collapse all and expand all does not work with German and Spanish keyboard layout

Collapse all and expand all does not work with German keyboard layout, because [ and ] are third options on key “8” and key “9”.
I tried Alt Gr+8 or 9 or Alt+shift+8 and 9 but everdo interprets this just as 8 or 9 and opens notebook or archive section.

Thanks you. The fix will be included in the next release if possible.


Alt+[ and Alt+] doesn’t work with spanish keyboard (QWERTY)
I have a Windows 10 device.

Many thanks.


Alt+[ and Alt+] doesn’t work with spanish keyboard (QWERTY)
I have a Windows 10 device.

Many thanks.

I guess this is the same bug

Thanks @manu :+1:

@Andrei Could you please include the Spanish keyboard in the next release?

Many thanks. Rgds. J.

Created a ticket, thank you.

Works like a charm wit 1.2.17

Sadly I have to say that the keyboard command and the button behave differently.
Could it be that the keyboard shortcut is implemented for a single item and the menu button for all items?
I tried re-opening the app, but the behavior still is the same.

Could you please clarify what works and what behaves differently?

the button does a collapse / expand all and the keyboard shortcut only collapses / expands the selected item.

The Collapse / Expand keyboard shortcuts doesn’t work with Nordic keyboard layouts.
The ] character requires you to press Alt Gr and 9 on nordic keyboards.
Alt Gr + ] expands the selected item, but Alt + Alt Gr + 9 is not working at all.

/ Christoffer

As a heads-up from a Windows user with German layout. ALT+8 and ALT+9 does indeed collapse and expand, but not everything. Only the selected item will be collapsed and expanded. This would be nice if it worked! Thanks a lot

This issue has been around for a while, so I thought I’d update everyone.

The whole keybinding story is very confusing when it comes to European keyboard layouts. Basically Alt+8/9 works because that sequence corresponds to the ‘[’ character, which is bound to collapsing one item. But to collapse all, the application expects ‘Alt+[’, but Alt gets removed by the system, so the application only sees ‘[’ without the Alt. Hence collapse all is not triggered.

Basically, after spending many hours debugging this issue, the only 2 ways I can see for fixing it is to
a) Allow the user to reassign hotkeys
b) Come up with an alternative hotkey which works better across layouts

The option (B) would of course happen sooner, but I’m not sure that such a key combination exists.

For me CTRL+ALT+8 or 9 works to collaps/expand all items.
I could live with that, just had to figure this one out.

For solution B try to find a more common character that is not on the third position on the key, but on the second position which normally is reached by pressing shift.
Then you should be good to go.

  1. lowercase reached by just pressing the key,
  2. Uppercase reached by pressing shift + key
  3. special less common chars, reached by pressing ALTGR + key

What about “<” or “>” ?

Generally I would prefer one shortcut which toggles between collapse and expand.

Also CTRL + “+” does expand, is this intentional?

Manu is right, it works for me, only with left ALT though.

So: LEFT CTRL + LEFT ALT + 8/9 collapses and expands all issues.

what’s up with this shortcut?

I’m not sure how to even type CTRL+"+", since the plus is in the top row on English QWERTY, so I need to press Shift+"=" to get “+”. But Ctrl+Shift+"+" did nothing when I tried it.

okay, neve rmind it’s not that important.

Could you just change your keyboard layout to german for testing purposes?

Of course, testing is not a problem here.