Crash after click on one item

version 1.5.14 Pro. Using Linux Mint 20.2. I have had a few updates to programs since last using Everdo, maybe a week ago, so maybe one of those has done this.

Open the program. Click on one thing, an item, the menu in the top right corner to look at the version number, anything I choose. At that point the program is not responding at all. The scheduled items that usually come forward into Focus, are not moving. It’s dead after 1 click. Let me know what other information I can get for you.


An update to Mint might have caused the problem. I run the same setup and have never had any issues but I’ve been out of town since the 4th so I don’t know if anything’s changed since then.

I moved ~/.config/everdo and restarted. I got the fresh set of sample entries and could work with it without crashing. I then copied only the db from the old everdo directory and could click a couple times into the process of editing an item when the program froze as before.

I then replaced the entire old directory, and then copied only the db from the new directory into the old directory. The program worked fine. It would seem that there is something amiss with my db. Is there anything I can do about that? Thanks.

Back in business. I used the old directory of everdo config putting in the new db that was made as I said earlier. Then I opened up my copy on my tablet and pushed sync to the server. Once a week I pull sync. I have never synced to the serve before, so I’m sure I did not corrupt the db in that way. Not sure what happened, but the copy on the tablet was my latest good db, so it was an easy update after the sync.

If you want me to do anything with the db that causes the crash, let me know. I’ll keep it handy.