Error encryption keys mismatch, but keys match

I love Everdo and it has greatly improved my life. However, I can’t get the sync function to work, and I’d appreciate any and all help with it.

I use Everdo on two devices: a laptop running Ubuntu, and an Android mobile phone. At first, the local network sync worked, but then it got progressively buggier until I tried to use ESS.

On Login - Everdo Sync Service both devices show as authenticated. I followed the setup guide. The key is the same on both devices. I used the “generate random key” function and have not altered it. Both devices show the “encryption keys mismatch” error.

Additionally, the laptop shows “This computer could not sync with the Encrypted Sync Service. It can’t be used to pair other devices.” as error message when I try to use “pair mobile device”. (When I try to scan the QR code, nothing happens.)

I have used the “push” function on my phone, which has complete data (the laptop doesn’t). I doesn’t show any error messages. In the Log, the entry says “AutosyncLoop.kt - initiating sync (MainActivity).”

What am I doing wrong? Thank you.