[Fixed] Android app crash during pull

I discovered everdo this morning and I’m very excited to use it, infortunatly I ‘m not able to use the secure sync on my android device.
I’ m using the latest version from Google play (0.102.0), and tried also the apk available in this forum (998).
Sync works very well between my two Linux computers.

What have I tried :

  • setup secure sync manually and quick pairing
  • use the clean pull action or normal pull
  • app closed itself.

If I create a new task and push it, I’m able to retrieve it on other devices, so only the pull is concerned here.

Is there a place where I can find some logs to know what happened?

Thank you for your help.

Hello! I will look into this and let you know. Sorry for the trouble.

Thank you, Andrei!
Feel free to ask anything that can help you to diagnose the issue.
That let me some time to work on my script to migrate from Nirvana :grin:

I have found a probable cause of this bug. Will try to push an update soon.

Edit: you can try upgrading in Google Play now. (version 0.103.1)

Issue solved :tada:

Thank you for your support, you just won a new customer.

New user here, with the same issue after manual secure sync setup. How can I resolve this?

I will look into this. Meanwhile please make sure you have entered the correct encryption key - it’s most likely to cause issues.

Double checked today. Mobile app hadn’t even been able to push, so no encryption key inconsistency. .
Anyway, I fixed it by setting up the app in Windows, and then performing a quick sync setup from there.