[Fixed] Collapse/expand doesn't work for synced items

For a long time, I haven’t experienced this but recently manual notes collapsing/expanding by pressing triangle icon doesn’t work again for me.
I remember that it was reported many months ago and I thought it was gone.

For some items manual collapsing/expanding works and for others doesn’t. All within the same list. At least strange…

I assume it’s the latest version of the app?
I thought this was fixed a while ago.
Is there anything special about the items that don’t collapse/expand?

I’m not sure but it looked like affecting newly created items. But I’m not sure…

I can confirm this issue.
It affects all items that were captured with my android phone.

Items that were created on desktop do not have this problem.
Additionally it doesn’t matter whether “hide by default” is set or not.

@manu thanks, this is it. Items created on mobile don’t get collapsed or expanded until after app restart.
This will be fixed asap.

The same with iOS app

Today I created an item on windows at work and tried to collapse/expand notes on MacBook at home. For Everdo client on MacBook it was a synced item. The same issue occurred. I wasn’t able to expand the note until I restarted the app.

It looks like collapsing/expanding is broken for every item created in a different client, either mobile or desktop than the one that we try on.

The same conversely, I created an item on my MacBook and today I can’t expand the note on windows. After restart all works.

This issue is solved and the fix will be in the next update, soon.