[Fixed] Long tags break tag editor layout (Can't Edit/Delete a very long tag)

I accidentally pasted a URL into the Tags field instead of the body of a task, and it’s essentially broken editing tags at all…

Here’s a screenshot - as you can see, the super-long tag has pushed the edit/delete buttons (for all tags) out of view, and the window is not resizeable or scrollable.


As such I cannot edit or delete the tag to remove it. I’ve tried editing the tag on Android (which works, because it’s a long press), but the rename doesn’t seem to sync back to the desktop (possibly a separate bug?). I also tried removing the tag from all actions, but it isn’t removed from the tag editor, even then.

Is there some other way to clean up this situation?

I’ll make sure this is fixed as soon as possible.

In the meantime, to edit other tags on the desktop you can try searching for them (I assume this should fix the layout issue by removing the long tag).

Also, you should really be able to edit the broken tag on the phone. Could you please try that again and see what happens. Do other tags get synced? What about if you edit both the title and the type?

That does indeed work, thanks! Should have thought of that :slight_smile:

OK so I tried:

  • Create a new tag “test1” on Desktop, apply to task, sync
  • Sync phone, see “test1” on task
  • Edit tag to “test2” on phone, sync
  • Sync desktop, name does not change
  • Remove “test2” on phone, sync
  • Sync desktop, “test1” does disappear
  • Add “test1” again on desktop, sync
  • Sync phone, “test2” reappears

So tag presence is definitely being synced - but not the attributes. I assume (guessing at internals :P) that the sync is working on tag IDs, and the name change is not propagated.

As for type: repeating the above process, but also changing type to Contact when I edit the name does not change anything. I end up with “test1 - Label” on desktop, and “test2 - Contact” on the phone. I see the same behaviour with Areas - however, it’s not consistent, at least once or twice during my 10+ tests a change to Area did sync back. Perhaps a race condition?

Interestingly, this looks like a oneway problem - any changes I make on the desktop always sync to the phone - names, types, all seem to copy over just fine.

Thanks for the fast feedback! As a bonus, I managed to hit the above race condition on my problem tag by changing it to an Area with a shorter name, and that synced to the desktop, so I’ve managed to delete the tag now. So there’s no hurry on a proper fix :slight_smile:

I guess I should add some version information:

  • Sync server - Everdo 1.2.17 AppImage on Debian 10
  • Desktop used for testing - Everdo 1.2.17.pacman on Archlinux
  • Phone - Everdo Android 0.90.0