[Fixed] "Next" section broken


#1

Debian 9.5
Everdo 1.1.8 free

Dragged a task into “Next” and now the “Next” section is broken. Hitting the “n” key doesn’t do anything. Switching to “Next” section gives this error in the console (or log):
[17:57:27.215] [error] TypeError: Cannot read property ‘num_parallel_actions’ of null
at file:///opt/Everdo/resources/app.asar/bundle.js:30:66852
at Array.reduce ()
at o.sequentialNextActions (file:///opt/Everdo/resources/app.asar/bundle.js:30:66805)
at iA.get (file:///opt/Everdo/resources/app.asar/bundle.js:7:21350)
at iA.evaluate (file:///opt/Everdo/resources/app.asar/bundle.js:7:22500)
at o.sequentialNextActions (file:///opt/Everdo/resources/app.asar/bundle.js:7:25692)
at o.groups (file:///opt/Everdo/resources/app.asar/bundle.js:30:56170)
at iA.get (file:///opt/Everdo/resources/app.asar/bundle.js:7:21350)
at iA.evaluate (file:///opt/Everdo/resources/app.asar/bundle.js:7:22500)
at o.groups (file:///opt/Everdo/resources/app.asar/bundle.js:7:25692)


#2

Looking into this. Thanks for reporting.

This might be related to a rare sync bug reported earlier. If so, then a quick fix is to do a push or pull depending on which device doesn’t work.

I any case, an update with a proper fix is coming


#3

I’m not using any sync functionality, but I don’t rule out bugs crawling into spaces they aren’t meant to be :slight_smile:


#4

Oh I see. This bug is caused by data inconsistency - some action refers to a project that does not exist. Not sure how this could have happened. But this sqlite script should fix the data for now

update item set parent_id = null 
where id in (select i.id from item i where ((select count(*) from item p where p.id = i.parent_id) = 0) 
and i.type = 'a' 
and i.parent_id is not null);

The database file is at .config/everdo/db

Sorry for the troubles…


#5

Update on this: Installed 1.1.9 and the issue has been fixed. Did not have to run any sqlite commands.

Thanks, this must be the fastest bug report -> resolution I’ve ever personally experienced :slight_smile:


#6

The same error happend to me (Windows 10 machine). All my items are lost and i cant create new ones. Running the sql command did not change anything (version 1.1.9) and reinstallation also did not help (just running installer again).

[2018-09-19 08:38:49.377] [error] TypeError: Cannot read property 'id' of null at /AppData/Local/Programs/Everdo/resources/app.asar/bundle.js:40:100141 at Array.forEach (<anonymous>) at /AppData/Local/Programs/Everdo/resources/app.asar/bundle.js:40:100117 at Array.forEach (<anonymous>) at t.default (/AppData/Local/Programs/Everdo/resources/app.asar/bundle.js:40:100092) at AppData/Local/Programs/Everdo/resources/app.asar/bundle.js:172:45413 at Array.map (<anonymous>)

Note: i removed file:\\\ prefxi.

I really like the app, but loosing data would kill it for me.


#7

Sorry for the trouble. Nothing is lost, don’t worry. There seems to be a bug building the list, the data is there.

Does this only happen when opening Next, or in other lists as well?


#8

Could you please try running this script and see it fixes the problem?

delete from tagitem where tag_id in (select tag_id from tagitem where not exists(select * from tag t where t.id = tag_id));

Another one.

update item set contact_id = null where contact_id in (select contact_id from item i where not exists(select * from tag t where t.id = i.contact_id));

Pretty sure one of those will fix it. Once confirmed we can publish a code fix promptly.


#9

@mgrani, All right probably no need to bother with SQL anymore. Grab a new build which should fix this: https://d11l8siwmn8w36.cloudfront.net/1.1.10/Everdo_Setup_1.1.10.exe

If it’s not too much trouble, maybe you remember if you were doing anything with tags/contacts/waiting for tasks before the bug occurred?


#10

thanks for that very fast support. Great! :grinning:

The second query fixed it. I’ve installed the new version, but only after fixing the database


#11

Yep, that’s what I though more likely. Thank you for confirming!