[Fixed] Tags disappearing, push error


#1

I Have made a new project and added tasks. I added a tag to the project to be applied to all tasks, this tag is also used for tasks not in this project.

When I click on the tag to filter for only tasks with that tag everything is fine but once I click away from this view to anywhere else the project loses all tags as well as all of the sub-tasks.

I am seeing this issue on Windows 10.


#2

I tried this a couple of times, but couldn’t reproduce the issue. I think some key details are missing so I didn’t do it right.

Which view is active at this time?

When and how do you notice the fact that both the tags and the projects are “lost”?


#3

I don’t know if it is related to what you explain, but I see another bug with tags: I recently updated my Windows (7) version of the app to try ESS (synchronization between my PC and my Android phone). When I create a new task on my PC in ‘Inbox’, the new task shows normally. But if I add one or more tags to it, and apply changes, the tags are added correctly, but a few seconds later (when synchronization occurs I think), all the tags for this task disappear (the task remains).
If I add the task on my phone, and add somme tags to it, I works well on the phone, then through ESS it displays correctly on my PC, but a fews seconds later the corresponding tags disappear…


#4

This probably means you haven’t made a Push from your computer to ESS during setup, so it doesn’t “know” some of your tags. Go to Settings, Sync tab and use the “Push” button once. The problem should disappear.


#5

Yes… I works now. Thanks.


#6

I have done some more troubleshooting and it doesn’t matter what view I am in.

everdo1

After adding a tag to a project it will add the tag to all tasks but if I wait it will remove them again. I also assume this is sync related.

I have been using ESS without issue and trying to push has not helped. All tags and projects are synced but adding tags from either Android or Windows will remove themselves within ~10 seconds. Very Weird.

Below I caught it Happening! I added the tag and saved the project but if I go back to edit the project it will keep the tag from disappearing but below you can see all of the tasks have updated to no longer have the tag. Once I save again the project also loses its tag.

everdo2


#7

OK now I understand. It does seem related to the issue solved by a push. Maybe try it again? Make sure the device doing the push has all the tags (press T to verify).

If it still doesn’t help, a few questions to help diagnose the issue.

  1. Did you use network sync before ESS?
  2. If you rename a tag, does the change sync to other devices?
  3. What if you create a completely new tag and assign it?
  4. What if you create a new project and try to assign a tag to it?

#8

Yes.

Yes, editing old tags will update on all devices. Creating a new tag will also sync and stay applied to newly created projects and old ones.

I made a new project and added a new tag to it. It works just fine. if I add an old tag (from before ESS) it will disappear.


#9

I checked the logs and didn’t find a successful Push for your account. Please try it again sometime.

Here’s where the button is, just in case:
2019-01-12-10%3A59%3A08-select


#10

I just tried and received a successful sync message and them an error 500 and it is alternating between the two.

Capture
Capture


#11

Looks like the push crashes for you for some reason, which is why you still have the tags disappearing. I’ll take a look.