Letter "X" deletes tasks

I don’t know if this is considered a bug, but even though I have disabled all keyboard shortcuts, when I press X, Everdo still deletes a task. No way to turn it off.

I don’t see that “delete” is a key that you can configure or disable. At least I didn’t find a single default keyboard shortcut setting called “KeyX”
What do you expect? That delete by KeyX goes away magically just because you change/delete unrelated keyboard shortcuts?

Thus I’d call it a feature request.