Network sync issue


#1

Hey there,

as google rejects this mail as junk I’m posting this issue here in the forum.

Since some time I’am experiencing issues while syncing with my server instance.

My Everdo server with activated API is running in a QEMU-VM under Devuan (Debian). It uses port 11111 and when I’m in my home network everything works as expected because it can sync immediately. Now I’m on vacation and connected to my home base via VPN - but this is not always the case.

Theres no firewall in between, so sync between client and server should work as it does at home if I’m connected via VPN. But sometimes I’m getting the message, everything worked as expected (it didn’t as I can see if i connect to the desktop of my QEMU VM - more info on this issue as follows), sometimes it tells me messages like “Communication error: socket hang up” or “Communication error: ETIMEDOUT”

So the problem is that I changed a lot on client side and after it tells me “Synced Mon Feb 04 2019 15:20:41 GMT+0100 (CET)” on server side I can see nothing has changed.
I already tried to switch to “Manual Client” on my device and clicked on “Push to server”. Result: Nothing changed on server side either.

How can I help you to debug this issue?

I don’t want to copy manual json exports from my client to the server from time to time as this is a little bit annoying and I don’t want to mess up with all my connected devices.

Every client and the server itself is using the most up to date version 1.2.6.

EDIT: As stated in another thread, I can connect to https://192.168.1.1:11111/time?key=MYKEYGOESHERE without problems so I wouldn’t focus on the VPN connection.

Regards
Christian


unlisted #2

listed #3

#4

Christian,

There has been an important fix that affects Push functionality. Could you please try this updated version on the client and do a push again? https://everdo.net/download/1.2.8/


#5

Hi Andrei,

should I update the server as well?

Regards
Christian


#6

a) When you did this push manually, did you see the updated “last sync” time on the client?
b) When you add a completely new item on the client, does it sync?


#7

Ok so after updating to 1.2.8 on my client I tried the automatic sync as well as the manual sync (Push to server). Both still don’t work.

a) When you did this push manually, did you see the updated “last sync” time on the client?
Nope, it doesn’t change

b) When you add a completely new item on the client, does it sync?
nope


#8

Do you see any kind of error notification on the client?


#9

No nothing. No error message.

Is there any log I can look into?


#10

Sent you a PM for further discussion