[Resolved] Everdo 1.3.1 to 1.3.5 Upgrade Bug

Hi there,
Since version 1.3.1 I cannot update to any higher version on my Ubuntu Desktop and each time I wrote an error report.
Since nothing happened and I also never got an answer on my provided email address I thought I should go a bit more public with this annoying error.

Please see the Bug in action during upgrade attempt on this youtube video:

Hello! Sorry for the delay. I’m looking into this error right now.

It seems like the reason for this error is that some data is inconsistent in the database.
Could you run a query against the database and report the results? Here’s how to do it:

  1. Install sqlite3
    sudo apt-get install sqlite3
  2. Open the database
    sqlite3 ~/.config/everdo/db
  3. Run the query
    select count(*) from deletion where sync_id is null;

Meanwhile, if you are using the ESS sync, then you could try to fix this issue by performing a clean pull of the data from the sync server.

sqlite> select count(*) from deletion where sync_id is null;
23
sqlite>

But why does it shows that behavior only in verions higher then 1.3.1?
The desktop instance is my main server I pull from onto my mobile clients.
The mobile clients still hold the successfully pulled items from main.
Isn’t there a log file I could post to you while the new Version 1.3.6 is starting up?

Thanks. Please backup the database just to be safe, then run
delete from deletion where sync_id is null;
Afterwards run
select count(*) from deletion where sync_id is null;
again to make sure the result is 0.

This should fix the error.

This is a data inconsistency that was created by an old bug in the mobile app. This data issue was not critical and was not noticed before 1.3.1, but in 1.3.3 the code was changed in a way that requires this particular property to always be correct. It was not expected that some users might have this data issue, so the app crashed after the update. To make things worse, the error reporting service was malfunctioning in the last few weeks, so it looks like your reports got missing. Really sorry about that.

image
Awesome and worked emmidiately!
Ticket solved and thanx!