[Resolved] iOS sync error but server is accessible

Hi all,

I apologize if this seems like a duplicate, but I’d followed the troubleshooting instructions on https://help.everdo.net/docs/sync/network/ and did not have any success.

To be more specific, I configured my server with its IP and API key, and do see that it reports that the “server is listening” in the Settings tab. I confirmed this by going to the https://IP:port/time?key= on the server, and was able to successfully see a time value returned.

I then followed the same advice, and went to the same link on my phone (the client), and was also able to see a time value. That is, I was able to connect to that link successfully.

However, when I tried entering the same values in Everdo and tap “sync once”, I continue to get a communication error. I’ve triple-checked the values, so I don’t think it’s a user error (though it’s always possible). I thought that it might be a setting on my phone preventing apps from accessing the internet, or something like that, but I don’t see the option to tweak the app settings for Everdo on the Settings app in iOS.

Could there be something else I am missing?

It looks like you have done all you could to diagnose the issue. I will look into other possibilities and let you know as soon as possible.

Could you please PM me the specific values you have used in the sync configuration form?

I suspect the API key setting may be causing the error. Unfortunately it’s a known bug. If you have the API Key with any special characters, you can try changing it to an alphanumeric one and see if that helps.

Thanks, Andrei. I’ll send you the details via PM.

I actually did try changing the API key to alphanumeric after discovering another post with the same issue (though for ESS instead of local sync). However, I still ran into the same issue. Does the key have a specific format/requirement, or is alphanumeric the only known limitation?

Only some symbols trigger the bug, so an alphanumeric value should definitely work.

This is a definitive case of user error. The docs clearly state

  1. Go to the app Settings, open the Sync tab.
  2. In the Mode drop-down select Server .

If you only setup the API key, the /time will be successful from a web browser, but you will not be able to actually run the server. Apologies for taking up your time!