[Resolved] Search not functioning while in "Next" view

If I search for something while viewing “Next Actions,” I’ll only see results that are classified as “Next.” The results will not include Inbox, Someday, Notebooks, etc.

However, if I search for the same term while utilizing any other view, the search will yield all of the results. This shows that there’s something wrong with the Next view, not the application itself.

This has resulted in me duplicating tasks, as I search for something while viewing “Next,” find that there’s no task scheduled, and thus create a dupe.

Let me know how else I can help. I use the desktop version on Arch Linux.

1 Like

I just tried searching in Next and was able to see items that are in Inbox, as well as projects and so on. I think there must be something specific about the missing items that you have. Or some other detail is missing.

Here’s a screencap of the process. I created this task, “Testing out search,” minutes ago. It has no tags, categories, time, energy, anything that would’ve filtered it out of this view.


Thank you for the video. I have find a likely cause of this issue. Please try this version of the app and see if it’s fixed: https://s3.us-east-2.amazonaws.com/release.everdo.net/testing/Everdo-1.7.9.AppImage

Unfortunately the bug persists.

This one is driving me nuts, please fix this!

I still don’t have a reliable way to reproduce this unfortunately. I will continue looking but please let me know if you know how to reproduce it.

@Andrei @manu what version are you guys testing on?

I’m on 1.7.4
and I have to correct myself. The search works everywhere except in the Focus list - sorry for confusion.

And since I’m in the Focus view all the time, of course I start searching from there.

I have finally solved this. I will try to push out the update as soon as possible.

1 Like

I have posted a new build that fixes this issue in early access. Please check it out.

1 Like

Apologies, it’s been a crazy month and I haven’t had time to check this.

However I wanted to report that I just upgraded to the latest version and search seems to be working. Thanks for the great app :slight_smile: