[Resolved] Sync with mobile does not work after data import (communication error)

Hi there
After testing Everdo desktop and mobile in the paid mode I decided to migrated from NirvanaHQ. Now my sync does not work anymore:
On my phone I just have two active projects, and two someday projects synced. Although I have nearly 200 projects in total.
On my desktop app is Communication error: Status code 500.
I tried everything: clean pull from iphone, clean push from desktop, logout, reinstall…
it just does not work. Can somebody help me please… I ve spent the whole weekend on migration and now it does not work properly…

Do you have lots of repeating actions?

I’m looking into this.

From what I see at the moment it seems like a corrupted piece of data is being sent to the sync service, and it has trouble dealing with it.

I’m trying to figure out exactly which part of your sync payload is invalid. Have you imported data into Everdo somehow as you migrated from nirvanaHQ?

I think the sync issue is cased by the initial migration of data.

Some of your items have invalid id. Please note that id must be a valid UUID, so it must be 32 characters long.

This should really be caught during an import, but unfortunately it wasn’t

The list of bad ids:

'75F8257131F64CFD93D9DE16A7B4B85D20231101', '75F8257131F64CFD93D9DE16A7B4B85D20231201', '8B45163BC7A44C368B138255DD2F840920200818', 'BF1C2F07CC5B4E0786749EBC239A507E20231127', 'BF1C2F07CC5B4E0786749EBC239A507E20230828', 'BF1C2F07CC5B4E0786749EBC239A507E20231030', 'BF1C2F07CC5B4E0786749EBC239A507E20231106', 'BF1C2F07CC5B4E0786749EBC239A507E20231113', 'BF1C2F07CC5B4E0786749EBC239A507E20231120', '209A19C2B18149D69E9DDF4AA696CBC320230713', '103FEECF60A7433C9B99CF65918A99B820230810', '103FEECF60A7433C9B99CF65918A99B820231110', 'C85E77056E2442DD9982C6541A321C5420230925'

Then there is the recurrent_task_id property, which also must be a UUID (optional), but you have one item with BF1C2F07CC5B4E0786749EBC239A507E20231127.

Not sure what other issues might be there with the data, but the error I’m seeing in the logs at the moment is related to these invalid UUIDs.

Thank you for your quick reply.
We fixed the bad ids and the task_id
it still does not work. :confused:
do you see some more errors?

we solved it. Thanks!

Can you please let me know what the cause was in the end? I would really appreciate it, so that the issue can be solved for good.

If you don’t mind, I’ve edited the title to make it more searchable in case someone runs into a similar issue in the future.