[Resolved] Unable to license iOS app with multi platform license

Hello. I have an iPhone 13 running iOS 16.4.1 and app build 1.6.7-1, and I cannot share the key with the Everdo app from files and have the license applied. I have copied the key I have used before locally from google drive, and when sharing (from the apple files app locally), it adds it to the inbox showing a link to the file. If I open the file, the text inside looks like the typical random characters I have seen before in the key file. I tested it on another iPhone 13 and had the same experience. With previous versions, I have set up the application on an iPhone and iPad perfectly fine, but this time seems different.

When I try to download the key from the original purchase email and import it in, I get a key is a corrupt error. I am not too concerned with that, as I have a backup key I have been using for years.

Any tips on how to import the multi-platform key into the latest iOS everdo app?

Hi Jim,

I have just tried importing your specific key on an iOS 16.4.1 device and it worked. Here are the steps I followed. Please try to repeat them on your own device and let me know which step doesn’t work.

  1. Open the email app (I used the standard iOS email client).
  2. Search for “Your Everdo Pro Key”, then tap on the email search result.
  3. Tap on the attachment box at the bottom of the email.
  4. Tap the share button in the top right corner (it looks like a squre with an arrow pointing up).
  5. Find Everdo in the list of apps on tap on it.
  6. A pop-up appears with either a success or a failure message.
1 Like

Hi Andrei,

Following your steps I was able to get Everdo licensed, thank you.

Previously I was not starting from email, I was starting from the files app. Technically they key from the email was saved to google drive, saved down to the files app on local device, then I would share it prior to openeing or after opening and it would share the path. Now that I shared the key via the apple mail app, every time I open the file from the files app (reinstalling everdo fresh every time for testing) it licenses the appproperly. I assume going through the mail app we were able to create an association that propogated through other apps. One more thing to note, the key works in files when the icon shows a keynote icon, not when it was a preview of the text in the file.

Originally I was following the directions in the iOS app but the similiar step that would have broken would have been step 6. I had 2 license keys (likely a change to my info) and the ~700 bytes (not the 500 bytes) file worked.

Long story short, opening original email and sharing the key from the Apple Mail app works.

Thank you!