[Solved] Everdo segfaults on Arch Linux


#1

Hey Andrei,

first of all thanks for this fantastic application. Therefore I took the chance and went Everdo Pro this weekend.

Working and testing it at home on my Arch Linux box and on my Android worked absolutely fine. The issue just now occured, when I tried to start Everdo on my work machine (also running Arch Linux), as it segfaults here:

patrick.h****@patrick-t480 ~ % /opt/Everdo/everdo
[1]    30855 segmentation fault (core dumped)  /opt/Everdo/everdo

Digging a little bit deeper sudo coredumpctl info /opt/Everdo/everdo shows me:

           UID: 10007 (patrick.h****)
           GID: 10000 (domain users)
        Signal: 11 (SEGV)
     Timestamp: Mon 2019-07-29 10:42:29 CEST (1min 28s ago)
  Command Line: /opt/Everdo/everdo
    Executable: /opt/Everdo/everdo
 Control Group: /user.slice/user-10007.slice/session-2.scope
          Unit: session-2.scope
         Slice: user-10007.slice
       Session: 2
     Owner UID: 10007 (patrick.h****)
       Boot ID: 653320da4b224268b6658f8ccd994d38
    Machine ID: c13dee07343644388c71d6e605192221
      Hostname: patrick-t480
       Storage: /var/lib/systemd/coredump/core.everdo.10007.653320da4b224268b6658f8ccd994d38.30855.1564389749000000.lz4
       Message: Process 30855 (everdo) of user 10007 dumped core.
                
                Stack trace of thread 30855:
                #0  0x00007f1c8980fe71 _dl_relocate_object (/usr/lib/ld-2.29.so)
                #1  0x00007f1c89808412 dl_main (/usr/lib/ld-2.29.so)
                #2  0x00007f1c8981d41b _dl_sysdep_start (/usr/lib/ld-2.29.so)
                #3  0x00007f1c89806186 _dl_start (/usr/lib/ld-2.29.so)
                #4  0x00007f1c89805108 _start (/usr/lib/ld-2.29.so)

I have updated glibc from 2.29-3 to 2.29-4 (the -3 and -4 being package release versions), but in both cases I do have the same result. The funny thing is: On my home machine it does work without issues on the same glibc versions.

It is very well possible that other side effects could be causing this, but as I am no developer and the information from Everdo is unfortunately not very helpful, I was wondering if there is anything else I could do for debugging porpuses?

Thanks already and best regards!
Patrick


#2

Patrick, I will take a look. It does look like an environment issue or a bad library somewhere.


#3

Just a guess, have you checked what its being linked against?

Try ldd /opt/Everdo/everdo and check if you have all dependencies needed


#4

Thanks for this idea, but ldd only gives statically linked as output.


#5

I tried upgrading my Arch and everything still works…

As far as I’m aware, there’s nothing that can be done at application level to prevent this crash or provide better logs. But I’m not an expert on Linux OS-level debugging.

Do you have any other electron-based applications on your machine, like slack-desktop or vs code? Do they work?


#6

Nevermind, I just compared the Arch Linux package that had been created by my home machine and the one created by my work machine and the latter seems to have been corrupted, as it is also smaller.

I just installed the one from my home machine and now it is working (also, ldd now gives sensible output :wink: ).

If anyone else might see similar problems in Arch linux, maybe it helps to recreate the package completely from the Arch User Repository!

Still thank you very much!


#7

Great, thanks for the update!


closed #8