Tasks showing up twice


#1

How do I stop tasks from showing up twice as in this picture?
Task #3 is showing up twice in my Focus list. I expect that the recurring “template” task should not show in favorites but only the recurring tasks that spring forth from that should show up in Focus.

everdo%20tasks


#2

Simply remove the due date from the template - it makes no sense there. Then you’ll be able to un-focus it, thus hiding it from the focus list.

In order to have a due date on the repeating items, you need to set the corresponding checkbox in the scheduling dialog.


#3

I think I understand but it has been confusing having two places that say “due date” I was afraid if I didn’t set them both then the task would not fire off repetitively .


#4

Yes, it is confusing. It’s better to remove the ability to set the due date on the template task directly.

No, a due date in Everdo has nothing to do with scheduling - it only serves as a trigger to star the item permanently.