Android sync over OpenVPN


#1

Everdo is running on a server in my home. When my Android phone is connected to my home WiFi network, I can sync between the server and my phone without any issues.

Because I travel frequently, I access my home LAN via an OpenVPN device (a Raspberry Pi) to gain remote access to my server. When I connect my Android phone over LTE and OpenVPN, I can download FROM my Everdo server, but I cannot send data from my phone TO the server.

Any ideas? I would suspect an OpenVPN config error if I couldn’t get any connection, but being able to transmit data only one way is really strange…

Thanks!


#2

What do you do specifically to Download/send data?

If you initiate sync (swipe down), what message do you see?


#3

What do you do specifically to Download/send data?
If you initiate sync (swipe down), what message do you see?

I’ve used both the swipe down and the menu option.

I discovered today that for whatever unknown reason, I only have this problem when attempting a sync with OpenVPN over an LTE (T-Mobile) connection. When I’m on hotel / office WiFi and connect to my home servers via OpenVPN, sync works flawlessly. I have no idea why. :man_shrugging:

FWIW, when sync does fail on my LTE connection, I get a “Connection Error” message after the sync attempt times out.


#4

Lets try the test described in this post [Solved] "Communication error" message when trying to sync from desktop to android


#5

Tried it. Firefox Focus on Android gave me a “Secure Connection Failed” over both WiFi and LTE (T-Mobile).


#6

So, when you connect to the VPN over LTE, sync gives a “connection error”. In other setups sync works - without VPN, or VPN over WiFi.

At the same time the browser connects to the server and gives a security warning, which indicates that the connection exists.

I think we need to get a more specific error info out of the Android app. I will let you know once it becomes possible.


#7

Please update the app and try to get the “Connection error” with your VPN setup.
Then go to the app settings and tap the “Version” menu item (should be 0.76.2). The logs should have a more specific error description.


#8

Done. Replicated sync issue over LTE + OpenVPN. The log screen was completely blank. Sync continues to work fine over WiFi though.