Everdo Desktop 1.2.2, Encrypted Sync Beta- Everdo


#1

Encrypted sync is a new way to sync data across your devices running Everdo. The main benefit of ESS over the standard network sync is that it works seamlessly over the Internet. It means that devices don't have to be on the same network anymore. Each device is still fully autonomous and maintains it's own offline copy of data, but they also send encrypted updates to the ESS server, which makes it possible for multiple devices to share changes in the background.


This is a companion discussion topic for the original entry at https://everdo.net/blog/update-1-2-2/

#2

As usual, please post here if you have any questions or run into trouble.


#3

I installed the update on Ubuntu. The app starts with blank window (no interface elements visible) with no error messages whatsover.


#4

Hello,

Ubuntu 18.04 with Gnome, Everdo Pro here. I have just installed the .deb package for this new version and the program loads to a blank screen, even after renaming the ~/.config/everdo directory.

Everdo loads as expected with the .appimage version.


#6

The corrected deb package has been re-uploaded. Please download it again and re-install: everdo_1.2.2_amd64.deb.


#7

Trying today, it seems to work well !

Some questions :

  • what kind of server behind all this ?
  • do you know how much this feature will cost ?

#8

What would you like to know?


#9

Where do you keep data ? Microsoft server ? Amazon ?

Thank for the price I didn’t read well the article apparently. Do you know what’s happen to the price if we subscribe upon launch, go back to home sync then choose internet sync again ?

I’m currently trying everdo and right now it miss some features for my use.


#10

The servers are hosted by one of the best VPS providers. Shoot me a PM if you would like to know some more.

The price will remain fixed in the future for the accounts of customers who choose to extend the subscription during or shortly after the beta period. Think of it as the ealy adopter discount. It will alply even if there a pause between the subscription periods.


#12

Tried on two Windows laptop. It seems that Projects and Notebooks are not synced? Only a few of exising items are synced. I was using Everdo on one laptop, and installed a new one to try ESS.


#13

For me both are sync well.


#14

What if you create a new action or a new project, does it get synced?

If newly created items get synced correctly, then sync is working.

In this case try making a Push from the device which has all the data, and then a Pull on the other device. This should copy all of the existing data and solve the problem.


#15

Thank you for reply. I did the push/pull thing and it works now. This is fancy, just like a git!


#16

To give more understanding: the autosync only sends incremental changes. So if the existing data is marked as synced for some reason, then it will just sit there until you change it again. This is why a push can be necessary when first setting up sync on devices.


#17

I just signed in the sync service, it works really well, tasks get synchronized to/from my phone (Android) and my laptop (Linux) within seconds. The makes the app very practical, thanks!


#18

In the program, when entering the account, the name of the “login” field should be replaced with “email”.


#19

Today I have this error on sync :

Communication error: self signed certificate in certificate chain

I try every button (pull, push…) but nothing work.


#20

This can only be related to your network configuration - firewall, VPN, proxy, anti-virus and such things. Has anything changed?


#21

Maybe because ip in API section didn’t be right.

But now I’m signed out and I don’t achieve to loggin again. Is there a way to reset password ?


#22

Here’s the reset form Reset Password