[Fixed] Dragging an item into a particular project

There is a bug or at least strange behavior when a task is dragged from the list to project on the side panel.
When we drag an item and move it over the project list then the currently selected project has a green border. It is ok when we want to drop an item on a particular project. The problem occurs when we want to resign. When we catch the project it is very hard to not drop it there. It is easy to move an item into a project by mistake
Please look at the screenshot and where is my cursor and the project is still caught. I wanted to resign from dropping “New Item”.


I also have this issue! I wanted to reorder the tasks within a project and the item landed somewhere else and i had o search it…

This is probably how it has been working since version 0.0.1, but I agree it’s not the best behavior.
Thank you for reporting!

totally! is it possible to change copy / cut & paste from current mouse dragging to keyboard shortcut, like ctrl+c / ctrl+x & ctrl+v?
this probably could be better especially when there is multi-actions to copy / cut.

1 Like

This is an interesting idea. Though I think, copy, cut and paste usually imply no changes to the content being moved. This is not possible to achieve in Everdo, because not every class of items can exist in every list. So “copy>paste” becomes really “copy > coerce into new class > paste”.

Also the current drag and drop between lists is different for each specific list. For example dragging an item from anywhere to Focus will only set the Focus flag and not change the actual list of the item. How would that work with copy/cut/paste? Tag-based lists are like this as well. In other words, many current drag actions will simply do nothing in many cases where doing nothing makes sense, but I would expect Ctrl+c/Ctrl-v to do something every time.

I am seeing a problem specifically when re-arranging tasks via drag-and-drop.

If during drag-and-drop my mouse stays within the task list area, all is good.

If, while dragging and dropping an item, I move outside the task area, for example in the left side-panel, even by a single pixel, then I can no longer drop my item between other tasks. I have to let it go, and then drag it again, carefully ensuring I don’t move outside of the confines of that panel.

This is annoying, because:

  • The handle is very close to the panel limits. It’s easy to move just a few pixels to the left, and invalidate my dragging and dropping
  • When I have to re-arrange a tasks, I usually have to scroll all the way up or down. It’s easy for the mouse to move far away when doing these kind of broad movements.

I can consistently reproduce it on my client(MacOS 10.14.6 / EverDo 1.2.17). Let me know if you want me to produce a screen capture of it.

Thank you in advance.

1 Like

This was fixed and will come out soon.


Hello Andrei, was it solved or not? I can still reproduce it in version 1.2.18. thanks

Yes, it is better but still possible to reproduce it.

Ok thanks for info. Hopeffuly next version will solve it😉.

I thought it was fixed. Probably didn’t get all the cases. Thanks.

1 Like

I’m having a hard time reproducing this issue again. Could you please outline the required steps ?

When I slowly move an item to the project list, catch a green border (on a particular project) and slowly move back to the list then it works correctly - item stays as it was. But when I move an item around the side panel many times (changing the potential drop place) then it always goes somewhere - even if I move back to the list.
When I tried to reproduce this I got errors that I sent within the app.

It is hard for me to describe this in English. My apologies.

Yes I have the same experience.

I’m trying to do what you describe, but it seems to work fine.

Is it possible that you are actually dropping the item at some time while hovering over the navigation section? Are you using a mouse? If so, could you try using a touchpad to drag an item and see if anything is different?

I use only the touchpad but plugged a mouse and experienced the same issue.
How do you create this animation? Maybe I can create my own which could help you figure out what causes that behaviour?

I use https://github.com/phw/peek to record gifs.

Unfortunately, it is only for Linux.
I have recorded my screen as a movie.
Here is the link:
Very often during these “exercises”, I get errors that I sent within the app.

This is very helpful, thank you!

Hi Andrei,
another video from me. Same situation like Mateusz.

I found that it works well without errors in version 1.2.15. I will stay in this version until no prob ver.