[Fixed] Tags not sticking (and erasing themselves) on Android app with ESS enabled


#1

Using latest Android version with ESS enabled, I can add tags to an item but they get removed every time the app syncs. The other client is a laptop that is currently powered down.


#2

Looking into this. Thanks for reporting. Please add more details if you notice anything.


#3

Disabling ESS fixed it.


#4

Steps to recreate:

Using latest version of Android and Mac Desktop Client with ESS

  1. On Android, create new standalone action in inbox with tags, time, energy or due date set.

  2. Press checkmark to save.

  3. Wait for item to sync to desktop.

  4. On macOS Inbox, action appears as expected.

  5. On Android, open the action that was just created and try adding a tag. Press checkmark to confirm tag, then checkmark again to save action.

  6. On Android, action appears with its tag momentarily… until auto-sync occurs, and then the tag disappears.

Second issue: Actions with tags created on macOS app sync to the Android app, but with not tags.

Steps to recreate, using the same setup:

  1. Create a new action with a tag in macOS app’s Inbox.

  2. Wait for sync to occur.

  3. Item appears on Android app with no tags.

  4. Note: any changes to the macOS action’s tags do not appear on the Android app’s action, either.

The most frustrating version of this bug is below, because it results in the loss of data. Existing synced items (created prior to enabling ESS) that already have tags can have ALL their tags wiped out by attempting to change any tags on Android.

Steps to recreate, using the same setup.

  1. On Android, locate an action that already has multiple tags, synced between macOS and Android prior to enabling ESS.

  2. On Android, attempt to add/change tags. Even one.

  3. Wait for sync to occur.

  4. All tags are wiped out on Android AND macOS. The action remains, but the tags are all gone from both devices. (!!!)

#4 is a big one! This is actually how I first noticed this bug. I could not figure out why all of the tags on a project had disappeared, then realized that it happened to any item when I tried to edit tags.

Hope this helps. Let me know if you make any tweaks to ESS, since disabling ESS seems to be the culprit. Sticking with network sync until then.

  • Matt

#5

I saw that two Android updates were pushed out today. The first one I installed did not fix the ESS tags issue. Any changes to the second update?


#6

Hi Matt,
No, it’s unlikely. This bug seems to be very specific to your case - it cannot be reproduced by others simply following the steps you’ve described. I’ll send you some instructions that should help us diagnose the issue. Sorry for the inconvenience.


#7

For reference:
This issue happens when transitioning from the Network Sync to ESS.
To avoid it, it’s necessary to make a “Push” from one of your devices to ESS, as part of the configuration. Otherwise the ESS won’t have most of the data, including tags that have been created prior to using ESS.


#8